Back to overview
Resolved
Integrated status updates in Seerr channel
Jan 13, 2026 at 3:40am UTC
Affected services
Overseerr
Plex
Plex Certificate
Resolved
Jan 13, 2026 at 3:44am UTC
Service status page: https://status.zenquah.dev/
Affected services
Created
Jan 13, 2026 at 3:40am UTC
Starting today, status incidents with all services will be pushed to the Seerr channel on Telegram
Affected services